Phones unavailable
Incident Report for Skiddle
Resolved
Our phone lines are now open and working, thanks for your patience
Posted Mar 20, 2020 - 12:24 GMT
Identified
Our phone provider is currently experiencing issues so our 03333 Customer Care and Account Support lines are unavailable.

Support is still available via help.skiddle.com
Posted Mar 20, 2020 - 08:31 GMT
This incident affected: Phone lines and email support.