Email backlog
Incident Report for Skiddle
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 27, 2018 - 16:25 UTC
Monitoring
We have identified a backlog of emails on one of our processing servers. These emails are now being processed and the backlog is clearing.

If you receive a backdated email please disregard if no longer relevant.
Posted 9 months ago. Feb 27, 2018 - 13:49 UTC