Mastercard payment issues
Incident Report for Skiddle
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 12, 2018 - 19:45 UTC
Identified
Mastercard are currently experiencing issues authorising cards. If your card is declined please try an alternative payment method or try again later. Visa payments are processing without issues.
Posted about 1 year ago. Jul 12, 2018 - 17:49 UTC
This incident affected: Payment Gateway and Stripe Checkout.js.