Some high value transactions are being rejected on 3D Secure
Incident Report for Skiddle
Resolved
Transactions have been completing without issues for the last 30 mins using the mitigation measures we implemented.
Posted Mar 31, 2021 - 10:40 BST
Monitoring
The issue with the global 3D Secure Platform is still ongoing but we have taken steps to mitigate this issue, and all payments are completing without issues. We will continue to monitor.

More issues on the upstream issue can be found here: https://status.arcot.com/incidents/tllk7p92422z
Posted Mar 31, 2021 - 10:10 BST
Identified
We have identified an issue with Visa's 3D Secure platform which is causing some higher value transactions to be rejected.

More info https://cardinalcommercecorporation.statuspage.io/ and https://status.arcot.com/incidents/tllk7p92422z

We're switching to an alternative payment provider to hopefully alleviate the issues.
Posted Mar 31, 2021 - 09:29 BST
This incident affected: Payment Gateway.