We're experiencing some slow response times on our website
Incident Report for Skiddle
Resolved
All systems have been stable since 19:25 with no further issues.
Posted Mar 25, 2021 - 21:09 GMT
Monitoring
Response times have been stable since 19:25. We're continuing to monitor to ensure stability
Posted Mar 25, 2021 - 20:48 GMT
Identified
We're currently investigating the cause and will update shortly
Posted Mar 25, 2021 - 19:20 GMT
This incident affected: Skiddle Website, Skiddle API, and Promotion Centre.