Slow page loading on Skiddle.com
Incident Report for Skiddle
Resolved
This issue was found to be a slow loading javascript file being delivered by Google. The issue has now been solved upstream and page load times have returned to normal.
Posted 2 months ago. Mar 13, 2018 - 21:01 UTC
Monitoring
Some pages on the website may load slowly, this is due to a 3rd party service having issues causing a delay in our page load speed.
Posted 2 months ago. Mar 13, 2018 - 16:32 UTC