Phone lines closed
Incident Report for Skiddle
Resolved
This incident has been resolved.
Posted about 2 months ago. Apr 04, 2018 - 12:22 UTC
Identified
Our phone lines are currently closed due to a power cut at our offices. Latest estimates are that power will be resumed at 3pm. Please check https://www.skiddle.com/help for support.
Posted about 2 months ago. Apr 03, 2018 - 13:34 UTC